UnoEuro & One.com WordPress Fejl

Fra 1. december 2018 udgår PHP 5.6.

Derfor vil alle hjemmesider og webshops, som stadig PHP 5.6 gå ned.

WordPress hjemmeside nedbrud skyldes ny PHP opdatering.

Fra 1. december 2018 udgår PHP 5.6. Derfor vil alle hjemmesider og webshops, som stadig anvender denne version gå ned.

Det betyder at hvis din WordPress hjemmeside eller webshop anvender PHP 5.6, vil UnoEuro & One.com tvinge dig til at opdatere, og hvis ikke du opdatere, vil din hjemmeside holde op med at virke.ngere op til de hastighed- og sikkerhedskrav, som stilles af brugere såvel som Google.

Hvorfor skal jeg opdatere?

Først og fremmest vil din hjemmeside gå i sort, og du vil kun blive vist en HTTP-fejl 500, hvis ikke du opdatere i tide.

PHP 5.6 er efterhånden ved at have et par år på bagen, og lever derfor ikke længere op til de hastighed- og sikkerhedskrav, som stilles af brugere såvel som Google.

Den største grund til at opdatere er at PHP 5.6, grundet dens alder, har en hel del sikkerhedshuller, som hackere kan udnytte, til at overtage din hjemmeside eller webshop, og stjæle dine- eller dine kunders data.

Derfor vil udbydere af webhoteller såsom UnoEuro og One.com, efter 1. december ikke længere understøtte PHP version 5.6. Vælger du ikke at opdatere din hjemmesides PHP version vil din hjemmeside gå helt i sort.

Det anbefales derfor, også at du opdatere din hjemmesides WordPress version. Til den nyeste version, således sikre du at WordPress understøtter den nye PHP version.

Nyt i PHP 7.2

7.2 indeholder de nyeste sikkerhedsopdateringer, som sikre din hjemmeside mod hackerangreb. Denne nyeste version af PHP, er udgivet 30. november 2017, og vil aktivt modtage sikkerhedsopdateringer frem til 30. november 2020.

En anden stor opdatering fra 5.6 til 7.2 er at “source koden”, har fået en gevaldig opdatering, som sikre at din hjemmeside eksekvere så hurtigt som muligt.

Opdater WordPress

Når du skal opdatere din WordPress installation, er det ekstremt vigtigt at du husker, at tage en fuld backup inden du går igang.

Alt efter hvor gammel din nuværende WordPress installation er, kan der nemt opstå problemer, ved en eventuel opdatering. Du skal derfor sikre dig at du har styr på, om dit tema og dine aktive plugins understøtter den nyeste WordPress installation. Ellers vil du kunne risikere, at din hjemmeside ikke fungere efter opdateringen. Eller værre endnu, at du mister data.

wordpress version stats

I skrivende stund, anvender 25% af alle aktive WordPress installationer(kilde wordpress.org), en allerede forældet version af PHP. Fra 1. december 2018, vil det tal stige til over 62%. Hvilket er alarmerende højt.

Det står ikke helt så slemt til med opdateringen af WordPress installationerne i sig selv. Men her er det vigtigt at huske, at WordPress er “first line of defense” når det kommer til beskyttelse mod hackerangreb. Derfor er det altså mindst lige så vigtigt at hold WordPress opdateret.

Har du spørgsmål?Kasper Stück